Class vs className exercise editor not loading


#1


I am having issue with class vs className exercise.

Whenever i load the exercise Code Editor and Web Browser section appear empty and they are greyed out. I can't click on the editor to change any code as the editor is not loaded. When i open chrome developer tools i see the following error in console:

vendor.bundle-3b337fb….js:56 GET https://www.codecademy.com/api/management/v1/instances/user/4f814f8c1b51d700030081cd/workspace/learn-react-01-03-01b 404 (Not Found)

I have tried to refresh the page, log out and log in but still the error keeps coming back and i can't finish the exercise. I am on OS X El Captain latest version and Chrome latest version.


#2

I have this problem on multiple exercises.
Reloading the page (until a "connecting to codecademy" appears at the top right) helps eventually.


#3

I have reloaded over and over again after few hours also and still the editor fails to load.


#4

After many retries editor has started working. The exercise system is quite buggy. After every few exercises editor stops loading with the 404 error and the error fixes after many retries. It is getting frustrating and difficult to complete the exercises when you have to keep refreshing to move forward.


#5

Indeed very(!) annoying. I tried some other courses and they didn't seem to be affected. Strange.


#6

Just wanted to add, same problem here. Editor is is often greyed out (not loading). Tested on Mac with Chrome and FF:


#7

Try doing a hard refresh > command+shift+R
It works for me that way.


#8

I do a hard refresh but sometimes it takes multiple tries to get the editor to show up. I am able to move forward in the course but after every few exercises the editor gets stuck and it takes many tries to fix it even with hard refresh.


#9

you're right, it's not very consistent, I had more success with hard refresh that regular one but not great.
BTW, Quiz section is messed up too, can't select some responses.
Not sure what's going one at CA :stuck_out_tongue:


#10

I'm having the same problem.


#11

try reloading the page or restarting the exercise.


#12

Repeated reloads over the course of several hours finally got this to work right for me; previously it would just spin endlessly when I clicked "Run".


#13

editor is loading fine now, it's just very slow, anyone else facing that problem?


#14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.