CD to Initialize Repo is Not Working


#1

I'm stuck on step 3 of the process. No matter how I phrase the name of the repo I recieve the same error message
"No such file or directory"

I am attempting to navigate to https://github.com/sbamberger127/sbamberger127.github.io

I use the following command

cd https://github.com/sbamberger127/sbamberger127.github.io

I have tried adding/removing "remote" into the cd command, changing http to https, removing a "sbamberger127", and many other variations to no avail.

What am I missing?

*EDIT: I have gotten the remote add origin command to work but the exercise won't let me move beyond.


#2

I'm also confused what we should put in cd. There are not clear instructions. Thanks!


#3

I don't think they want us to cd to a website address here, but to the personal-website folder in the workspace. However this folder doesn't exsist.


#4

I think you all should first create a new directory in terminal using mkdir command, and then select that directory.


#5

I tried that, but then in step 4 nothing will get checked although I'm entering the correct commands.


#6

I tried doing this but now have only compounded my issues. I cannot create the directory because it exists but can't navigate there because it doesn't exist.


#7

Hey ... you need to create the directory again


#8

@sunny442 Where to create the directory? Do I make it up? I also cannot reset the exercise to go back.


#9

I have recreated the directory multiple times. It still does not let me continue forward with the exercise.


#10

I think I figured it out. you have to put "git init" after you put "cd personal-website"


#11

Using the "cd personal-website" command I then get the error "No such file or directory"


#12

first create the folder using

mkdir personal-website

then

cd personal-weebsite/
git init


#13

Instead of creating a new tab in the terminal like the directions say, use the tab that's already given. That solved my issue and got no errors. Hope this helps.


#14

2017 and this still isn't fixed. anyone even taking this course?


#15

That did the trick, been fighting with this one for an hour!:joy:


#16

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.