Can't progress. Codespace crashes page

I am currently on Effect Hook exercise 4. I would paste my code but I can’t interact with the page at all because when it loads it instantly crashes. I think it’s from a memory leak because the rest of my computer gets sluggish. My code was something like this:

useEffect(setInterval(setTimer((prev) => prev + 1, 1000))

I have tried resetting my progress for that lesson and it resets every exercise except the 4th one that is bugged. Any suggestions on how to fix this?

Try the following:

  • Go to the third exercise.

  • From the “Get Unstuck” drop-down menu, select “Reset Exercise” and click on the “Reset Exercise” link. It will reset the third exercise.
    I am not sure, but I think it will also reset the subsequent exercises.

  • If that doesn’t work, then go to the Syllabus page for the course. DON’T click on the “Reset Progress” button near the Course Progress bar as it will reset your whole course which is not what you want. Instead, select the module from the syllabus. At the bottom right, there should be three dots allowing you to “Reset module progress”.

1 Like

I wasn’t able to find the exact “Reset module progress” but I have tried resetting the whole React Part II module and again it resets everything except the bugged 4th exercise.

Update: I was able to finally get it to reset. Not sure exactly what it was, but I tried resetting the module as a whole instead of only resetting the Hooks sub-module and then reset my cache. Hard to say which one solved it but at least its solved.

1 Like