Can't install node packages for X-press publishing project

Hello,
I keep getting this error whenever I try to install node packages for the project X-Press Publishing
Unexpected end of JSON input while parsing near '...0.1":{"name":"whatwg-'

I don’t know what to do for it

the project’s link
https://www.codecademy.com/paths/create-a-back-end-app-with-javascript/tracks/back-end-development-capstones/modules/bapi-capstones-solution-code-and-next-steps/projects/x-press-publishing

I’m getting the same error…

The last 3 lines under dependencies should look like this, character for character:

    "supertest": "^4.0.2",
    "whatwg-fetch": "^3.4.0"
  },

Check, and then try the following:

  • In a bash terminal, type npm outdated and enter to list deprecated packages
  • Then, type npx npm-check-updates -u and enter to update all packages
  • Finally, type npm install to complete the updates and update the package.json file
2 Likes

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.