Can't Get Started


#1

I’m trying to begin the Python course; however, the very first lesson says to “Click Run to continue.” The Code Editor is grayed out for me. I cannot click any buttons nor can I type anything into the editor. Does anyone have any suggestions or tips? I’ve tried on Safari, Firefox, and Chrome – all have the same issue.

I’ve also tried other programs – I tried to start the JavaScript course, but had exactly the same issue. Help!

Please leave the following link in the post so we can find the unit module, else replace it with a link to the exact lesson:

Welcome! Python Syntax


#2

Thanks for posting the link; it earned your topic a Vote.

Have you tried a page Refresh (hard refresh with Ctrl+F5) or a different browser?


#3

Thanks @mtf. I have tried on three browsers: Safari, Firefox, and Chrome. I have also tried Refresh and the hard refresh. I’ve also cleared my cache and browser data.

I’ve tried on both a PC and Mac, too, with no luck. Same problem.


#4

Wish I had something better to suggest. The page opens and runs fine for me in Chrome/Windows 7.

Please submit a bug report from that lesson.


#5

I am happy with the in-browser learning environment. I just want to know how to install the correct version of Python (Windows 10 user) that will have the same syntax requirements as taught in the “Learn Python” course. Please help!


#6

You’ll need version 2.7.x, but I would suggest use a sandbox for that version and install 3.6.x or newer for your own local environment.


#7

Hi!

I’ve the same problem. Do you solve it?

I’m frustrated cause I can’t begin the course. ;-(


#8

Hey same issue! This is super frustrating! Please please please get it fixed ASAP! Hope it works soon!


#9

same issue plz help fdhds


#10

your a kind guy :smiley:


#11

So I’m not quite sure what the issue was. I created a new account and haven’t had any issues since then. The account I was using when I posted this originally was created by using my Sign in with Google credentials. I simply created a regular sign in account with new credentials, and, like I said, that solved my issue. Not sure if the reasons are related.


#13

did not work for python code


#14

I had exactly the same problem and fixed it with a new “regular” account. Thanks!


#15

Try a new account without the pro version


#16

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.