Can't execute command in 6-th step


seems like something is wrong but still can't get what exactly. the command looks like valid


The command looks great. I have noticed that if you make a mistake and type the git command before you use the q to get out of the log then the code checker gets a bit confused.

Under Get Help there is an option to restart this exercise. You can use that to get a fresh start and try again.


Unfortunately this didn't work for me.


I have the same problem.
Besides, I can copy symbols but I can't paste them.
And when I type them - it does the same error.
I assume it wants us to paste it. But I am not able to do that.
Not Ctrl+V, not Insert, not right click


Same for me. Seems like bug.


Same problem here, I've been stuck on this exercise for a while now even though my code looks exactly like what's displayed in the picture. As another poster said, it just seems to be a bug, and there doesn't appear to be any way past it even after resetting the exercise (for me, anyway).


Exactly same story. I reported bug, may be you should too - then they'll fix it sooner!


I used the very last commit lines SHA first 7 characters (manually entered)


Having the same problem.
I've tried it too do it manually but still not working :frowning:


I too have same problem. :frowning:


I have found that if you reset the exercise. And it says that all your files have been fixed. Then you try it again. The issue appears to be fixed.

Add .gitignore

$ git reset d640dc3
Unstaged changes after reset:
M scene-2.txt
M scene-3.txt
M scene-7.txt


did it work, my solution is no, input 'git reset 7characters' is simple, but report errors


you just put git log


I try with another txt and work. scene-3.txt


It just doesn't work. I tried, it just doesn't work!


didn't work for me. I just don't know what to do...


Hi everyone! Try to reload the terminal (Right-click - Reload), then
git log
git reset 7be7ced - I typed first 7 symbols of SHA manually from the commit for scene-3.txt (not the latest commit), and it worked


works for me.
I reset the third or fourth commit and it works!