Cannot type anything in the code editor in learning SQL


#1

I'm trying to learn SQL. I'm using a Windows 10 machine and have tried using the Edge browser and IE11. I just cannot enter any text in the code editor.


Cannot type anything in Code Editor for SQL and Java
#2

Oh got it now. You have to hover the mouse half way down the until you see the cursor then click half way down the screen and you can start typing.


#3

I'm glad to hear that you sorted that out. Could you please post a screenshot of that so I can see what Win10 users are seeing?


#4

Having the same issue here. Using Safari on Mac. Nothing will happen in that windows. So confused.

It reads: code editor: open files here to edit them. But there does not seem to be a way for me to even open a file.


#5

Oh I got it.

Switched to chrome. Problem solved.


#6

im in chrome but it still doesnt work


#7

there's a screen shot but it doesn't show the cursor. If you hover the cursor over the code editor section near where you would expect to click to enter your code then you cannot edit/write any code. You have to hover/click about half way down the code editor section to be able to edit/write any code.

When you hover over the top section of the code editor the cursor will be the 'pointing finger' so then you move and hover half way down and the cursor changes then if you click you can then start entering your code in the code editor section.


#8

Thank you for that great explanation!

Have you reported this with the "Report a Bug" tool?

If you have time, could you repost this over in:
http://discuss.codecademy.com/c/Codecademy-Community-Lounge/Codecademy-Platform-Problems-and-Suggestions -- I could move this over there but then it wouldn't be here anymore. :smile:


#9

Are there any other methods for solving this issue (settings or otherwise)? I can find the area in my code editor window where the pointer changes to a text cursor, but clicking it does nothing. The text just below the section simply says, "Code Editor Open files here to edit them"

I'm on my work computer which is heavily administered using IE10 so using another browser is not an option for me.

I am able to use the code editor in other courses such as HTML and CSS, but not the SQL course.


#10

2 posts were split to a new topic: Where is the code editor


#12

2 posts were split to a new topic: "Analyzing Business Metrics" does not let me type in the code editor


#15

A post was split to a new topic: Is this worth trying?


#16

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.