Cannot install in bash!

Please see the attached screen grab. I’ve installed Node.js, but have not idea why the command provided in the lesson will not work. Stuck on step 1. Not even sure where to start with this. Here is the article link:

I don’t have access to the lesson (because I don’t have Pro), but the error directly tells you permission denied. What do you think that means? :wink: It tells what you should do about the problem.

Hopefully you followed all the instructions and tried the command with sudo since you have a permission error.. I have no access to the lesson and just noticed your “newer” post you created. :woman_shrugging:

I should have been more specific. I don’t know how to grant permissions where they are needed to make this run.

add sudo

sudo npm install -g ......

Awesome, that worked. Looking up “sudo” command now. Thanks!

Weird, I’m admin on this machine, not sure why I didn’t have permissions. . . but it is working.

Also, this is what displays when entering $PATH. Is it possible that I changed the directory of install to a python folder? Not sure where this thing is suppose to live - as in what directory it should be housed in.