Cannot finish with 10.Methods 2


#1

Cannot move beyond this step even though my code is working
chap 10 Methods


#2

Did you try to troubleshoot it a bit? Have you tried taking out the space after spike.run?


#3

i am having the same problem with that exercise and i also tried putting space after the bark method.


#4

I am having the same problem even though I used sample code offered by interface.


#5

Same problem here but at the first step of chapiter "10. Method II"
Whatever I do I get the "Did you create the run method? Place it between the bark and main method." error. I cannot continue the lesson even with provided code.


#6

Can you post a screenshot that shows your code and terminal session and all messages that appear.


#7

@albionsrefuge
Sure.

(Of course I try step by step without System.print.ln etc)


#8

I have the same problem.


#9

I think that you are getting too far ahead of the code checker. Just put what it is looking for in Step 1.

public void run() {

}

#10

I reset the exercise and do it step by step. Finally it works, thank you.


#11

As I said I already tried to just put the code the checker wants to see.
But I'll try to reset the exercice like alex_un.


#12

If the interface appears stuck and nothing you can do appears to work, try using a different browser. I had a lock up condition on my page when using IE11. After having complained on the forums and no help at all from admin, I used Firefox and got it going. My IE11 page is still stuck.


#13

Trying a different browser is a good troubleshooting step and if it works it lets you get on with the course.

It is always good to post any troubles especially browser related like this because it helps others.


#14

How do you reset step 10?


#15

Just click the 'reset code' button on the bottom of the page.


#16

I'm lost......I've tried resetting the code and switching browsers multiple times yet I'm still getting the same error message


#17

Using Chrome... already reset exercise and retyped code as shown... any ideas what I am doing incorrectly?

(In case photo text is too small)

class Dog {
int age;
public Dog(int dogsAge) {
age = dogsAge;
}
public void bark() {
System.out.println("Woof!");
}
public void run() {
}
public static void main(String[] args) {
Dog spike = new Dog(5);
spike.bark();
}
}

Did you create the run method? Place it between the bark and main method.

  1. In between the bark and main methods, add a method called run to the Dog class by typing:

public void run() {
}


#18

I had the same problem. Finally I just gave up and clicked "Get Code". This section is not working correctly and should be reviewed.


#19

A post was split to a new topic: Reset code and re-entered but still will not pass


#20