Codecademy Forums

Cannot download jupyter notebook with Anaconda Python 3

Hello!) I have a pro account right now, and I’m stuck at this Python 3 exercise:
https://www.codecademy.com/courses/learn-python-3/informationals/python3-reggies-linear-regression
MORE DETAILED: https://www.codecademy.com/articles/how-to-use-jupyter-notebooks

When I type “jupyter --version” into my command line, it outputs: “NameError: name ‘jupyter’ is not defined” when it should output the version of jupyter notebook on my P.C. I installed the Anaconda Python version, and when I type: “conda install jupyter” it outputs “SyntaxError: invalid syntax”. I followed the instructions carefully when installing Python…Could you help me please? I would be really grateful !:disappointed_relieved::sweat_smile: ! Here is a screenshot of the errors:%D0%91%D0%B5%D0%B7%D1%8B%D0%BC%D1%8F%D0%BD%D0%BD%D1%8B%D0%B9|690x316

Hello :slight_smile:

These commands should be executed in the system terminal - cmd or PowerShell in Windows. Not in the Python shell.

1 Like

Thank you very much for replying :grinning: I tried executing these commands in the cmd, and it gave me this output:


The translation is: jupyter is not a command and conda is not a command

And it said the same when I tried doing it in PowerShell :thinking:

Ok, we are getting somewhere :slight_smile: That is a much better error than before! :slight_smile:

Your terminal thinks that jupyter and conda are not installed. This usually means that the PATH environment variable does not include paths to binaries of conda and jupyter.

I am not a Windows user, but I will try my best to help you set up this variable. Here is a video showing how to do that -> https://www.youtube.com/watch?v=RaECVjRhyF8 on Windows 10.

Important - you need to add two records to the PATH environment variable - one with the installation path of conda and the second one with installation path of jupyter.