Bug: Nano is completely missing


#1




I am currently on page 6/11 of the Enviroment section (https://www.codecademy.com/courses/learn-the-command-line/lessons/environment/exercises/variables) but this problem persists across all lessons in this class.

Nano (and other commands) seem to be completely missing from my terminal. I had no issues with it last night, but tonight, the command doesn't work. Here is my output:

codecademy@2e07a9bb7584:~/music$ nano ~/.bash_profile                                          
bash: nano: command not found                                                                  
codecademy@2e07a9bb7584:~/music$ nano                                                          
bash: nano: command not found

I also performed a directory listing of the /bin directory (where nano should exist) and it shows that it doesn't exist:

codecademy@2e07a9bb7584:~/music$ ls /bin                                                       
bash          df             loginctl       sh                              umount             
bunzip2       dir            ls             sh.distrib                      uname              
bzcat         dmesg          lsblk          sleep                           uncompress         
bzcmp         dnsdomainname  mkdir          ss                              vdir               
bzdiff        domainname     mknod          stty                            wdctl              
bzegrep       echo           mktemp         su                              which              
bzexe         egrep          more           sync                            ypdomainname       
bzfgrep       false          mount          systemctl                       zcat               
bzgrep        fgrep          mountpoint     systemd                         zcmp               
bzip2         findmnt        mv             systemd-ask-password            zdiff              
bzip2recover  fuser          networkctl     systemd-escape                  zegrep             
bzless        grep           nisdomainname  systemd-inhibit                 zfgrep             
bzmore        gunzip         pidof          systemd-machine-id-setup        zforce             
cat           gzexe          ps             systemd-notify                  zgrep              
chgrp         gzip           pwd            systemd-tmpfiles                zless              
chmod         hostname       rbash          systemd-tty-ask-password-agent  zmore              
chown         ip             readlink       tailf                           znew               
cp            journalctl     rm             tar                                                
dash          kill           rmdir          tempfile                                           
date          ln             run-parts      touch                                              
dd            login          sed            true

The clear command also fails:

codecademy@2e07a9bb7584:~/music$ clear                                                         
TERM environment variable not set.

A screenshot showing all of the commands is below. Any help would be greatly appreciated. I'd really like to complete this class. Thank you!


#2

Yeah they broke the environment. Kind of impressive - even vi is gone and vi is almost always included, you probably have vi on your router and tv

You could.. download it :stuck_out_tongue:
Some headers are missing to compile it yourself, but you could use debian's nano package:

mkdir -p ~/nano
cd ~/nano
wget http://ftp.us.debian.org/debian/pool/main/n/nano/nano_2.2.6-3_amd64.deb
dpkg -x nano_2.2.6-3_amd64.deb .
echo 'PATH=$PATH:$HOME/nano/bin' >> ~/.bashrc
echo 'export TERM=xterm' >> ~/.bashrc
cd $OLDPWD
source ~/.bashrc
nano  # good to go

That can be completely undone by removing the two lines I add in ~/.bashrc and removing ~/nano

But then again if you're missing other commands as well that still might not get you far, for example, the exercise itself might be relying on various programs which could also be missing


#3

I started the command line course today, and it's missing for me as well. Everything worked except this. And I did the same as you, nano was missing.

Tried installing it following what 'ionatan' said, but stopped at the first echo line due to permission denied.

Please fix?


#4

I have the same problem :frowning:

can any one help with this problem fast ???


#5

I have the same problem at Enviroment 1/11. Kind of irritating screams inside. But it seems like this has only happened to us today so my best bet is that it will be fized in a few days. Fingers crossed. If you are bored make rubber ducky scripts. most of them use cmd or powershell. will be fun when you complete this.


#6

My guess is that you were writing to /.bashrc instead of ~/.bashrc - you don't have write permission in /

But since it looks like other things are also gone, there's probably gonna be half a dozen other obstacles to overcome.

Oh and I'm able to run vi vim nano, perhaps it's fixed now.


#7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.