BUG: Can't get past jQuery 11


#1

I have checked my code in various other programs and have had two front end developers check my code.
Yet the console will not accept it.

Please help I want to complete this course!!!

$(document).ready(function(){
$('div').mouseenter(function(){
$('div').fadeTo('fast', 1);
});
});


#2

Hi Littlevix151,

What does the error message you're getting say?


#3

Please see the attached image with the error message.


#4

I am hitting the same problem. Even when I copy and past the code from the example and hint I still get the same error about not setting opacity to 1


#5

same problem here. stuck on #11 for same reason.


#6

@littlevix151 Your code passed for me. Make sure you're hovering your mouse on the <div>, then moving off and waiting two seconds before going back to the editor :)


#7

I'm also having this problem... I noticed a few things about this chapter that were weird. Early on, the instructions were asking me to do things that were already in the script.js file, so I basically didn't even have to do anything to pass the lesson. In this lesson though, my code checks out but it continues to give me an error message and it doesn't work in the browser so I can't progress to the next step. Bummer. Codecademy please fix this!


#8

Same problem...(I am on french version)


#9

@littlevix151
I've found the solution !
The problem was the last semicolon.
You just have to remove it.


#10

Im having the same problem, go into the css file and change the opacity to 1. only way i can get it to pass.


#11

same bug can't pass because of it
checked in another editor and it is fine but here its not


#12

@neilwdy1 @ernestcode Are you guys able to get passed if you refresh the page or switch browsers?


#13

Hi Guys,
I think it is an internal bug ( it has a parsing error ), to solve this problem: try to switch the 2 function(mouseleave & mouseenter) as the following code:

$(document).ready(function(){
$('div').mouseleave(function(){
$('div').fadeTo('fast',0.5);
});
$('div').mouseenter(function(){
$('div').fadeTo('fast',1);
});
});

it will wok fine :wink:


#14

Go into CSS and remove the opacity property.

Unfortunately, you'll have to put it back in Step 12.


#15

On my version the problem was the script tag on the html page. The closing carat on the first script should not be around the word script. It should be right before the closing script. That is, the type and src should be within the first script tag.

This is what it defaults to

<script>type = 'text/javascript' src = 'script.js'</script>

And this is what it should look like

<script type = 'text/javascript' src = 'script.js'></script>

#16

To format your code to make it visible:
1. Paste your code.
2. Select all of your code.
3. Do Ctrl + Shift + C (Windows) or Cmd + Shift + C (Mac OSX) to format your code.

OR

1. Paste your code in.
2. Insert 3 backticks (`) before and after your code:

```
Code goes here
```

#17

How is this not fixed yet? It is clearly an internal error, and its been known for at least 2 weeks. Come on, code academy.


#18

@datajumper67047 Until we can reproduce the problem, there's no way to figure out what's causing it, so the only way it's going to get fixed is by accident for now. As soon as we get a way to reproduce it, we'll be happy to work on the problem!

Until we're able to do that, to get past this section have you tried:

  • Refreshing the page
  • Resetting zoom
  • Switching browsers
  • Disabling all browser addons/extensions

If you happen to find a way to reproduce the issue, please let us know! We'll be happy to do what we can to get it fixed :)


#19

This happened to me too - removing opacity from the CSS let me get past (thanks, eilwdy1.)

I'm using Firefox v.39 on Windows 10, no extensions or plugins, normal zoom, refreshing didn't resolve it.


#20

@maushawk Thanks for posting that! Out of curiosity, if you undo the CSS fix you made so you can't pass in Firefox again, are you able to pass if you use Chrome?