Bug? 4/7 Deploy a website


Bug? 4/7 Deploy a website.

<Below this line, add a link to the EXACT exercise that you are stuck at.>

<Below this line, in what way does your code behave incorrectly? Include ALL error messages.>
confirmation remote points to the repository. No instructions green check. Any idea?
<In this course, it often helps to include a screenshot of your whole web browser – that lets everyone see what you see. If you wish to include a screenshot, add it below this line.>

Image link https://drive.google.com/file/d/0B4nM2U96ZTv1TzVPV1lMdG1lWU0/view?usp=sharing

<If you wish to copy/paste in your code, you can use this next section. This will allow others to copy/paste your code for testing – something that they won’t be able to do with just a screenshot.>

Add the remote 4/7 box is not checked and can't move further!

Facing the same problem. Any lead to solve so far ?


same problem here…


Same problem here!!!

Tradução: Mesmo problema aqui!!!



back to 3/7 deploy website,
click get help and click I want to restart.

type in bash
Jekyll personal-website
cd personal-website
git init

now. you can follow the instruction

ps: don’t forget always use cd personal-website before excercise


Ok, i think i solved the issue.


but how?? I have done both steps one and two, the terminal says that my remote origin has been successful and yet still I cannot go further as the instructions have not turned green :frowning:


Hey I have been s=stuck on this for three whole days so I know what you mean. I have an idea just calm down if you have done the language git then look at that other wise if you have not do that and do command line cause they use those two languages :wink::wink::smiley::smiley::smiley::smiley::smiley::wink:


Sorted it. I stopped the server running that was started a couple of steps prior , then step 4 cleared first time - just an fyi for anyone else struggling.


sorry, i didn’t see the notification. Glad to see you solved it though.


Stuck on the same thing, even once said origin already exists, still no cigar, and no way to fail the lesson to default my way out.


Warning: long post mainly complaining

I’m also stucked at 4/7 and it’s getting very frustrating, as in not feeling in a code(a)cademy at all… I keep reseting steps, but the possibility to keep moving to next steps even after reseting doesn’t give me assurance and the unavailability to restart the “1.Create a Website” exercises doesn’t allow me to check previous steps.

This question is for those that feel stuck in a buggy way and don’t understand why: have you also done the ‘Command Line’ and ‘Git’ courses prior to doing this one? Have you done the hello-world tutorial in GitHub when you create an account?

I don’t know where I got to access the next exercise without really being fully prepared to do so, but I think it has been during the Jekyll exercises. If someone from the CourseCademy staff actually reads this, please, provide step-by-step guidance.

I cant continue the course

Ok… so I got it to work for me. I’m going to try explaining it for those in the exact same situation.

I restarted all the exercises one by one moving backwards and started again. I even created a repository with the same name provided in the example (user-name-cc.github.io). It is weird that the first instruction is met eventhough it says “No such file or directory”.

Because it says “No such file or directory” I create a personal-website and then change directories to it.

I do the “git init”.

Then I copy the sentence in the ‘Learn’ section (git remote add origin…), just changing the Github user name in that sentence to my GitHub account name. Here is the ‘tricky’ thing. The url we have to type ends by ‘github.io.git’ eventhough the repository we make in GitHub ends at ‘github.io’. So we need to add ‘.git’ at the end of our repository name! I didn’t do that before I think…

From here on I just followed the instructions.

I hope it helps!

Deploy a website Lesson 4/7 In the terminal, add the remote that points to the repository you created earlier. Use the example above to help you
I can not finish Deploy Your Website

thank u soo much for the screen shots. i followed the steps and it got me to the last screen shot u posted but it isnt moving to the next step…i havent gotten any further instructions. have any idea why?


Hi ushacares, so you get the “fetch” and “push” after checking that the remote was succesfully added by typing “git remote -v” and still cannot move further? In theory that should get you to 5/7.

Maybe you can type the instructions from 5/7 provided above to see if it lets you move forward. If not, I would recommend doing it all over again but taking screenshots when necessary and then post those here to see if we can help you discover what went wrong.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.