Blank web browser - Blank URL

Hi everyone! I am having an issue with the integrated browser in the lessons and wanted to see if anyone else has experienced the same thing!

I’m in the React Hooks lesson and I was having a great time. I put Codecademy down for a week and in the meantime made my account a Pro account. I just popped back in this week to resume my lessons and the browser is blank! It just says “Web Browser” and has no URL at the top.

So far for troubleshooting I have:

  • Refreshed the integrated browser
  • Refreshed my Chrome browser
  • Disabled all extension - adblock, etc.
  • Cleared cookies in Chrome
  • Updated Chrome
  • Switched browser to Safari (still encountered the issue there)

It seems to persist no matter what I do. I found a forum post from 2017 describing what I assume to be a similar situation: Web Browser Window Blank

Like in that post, I tried adding in “http://localhost:8000” to the URL, then hitting the refresh button, and it will just sit and spin forever. I assume that’s because it’s not on that port but I’m not sure what port it would be on.

Here is a screenshot:

I look forward to hearing from y’all!


hi just wondering if you got it sorted? im in the same situation

Have you tried resetting the exercise from the drop-down menu?

“Get Unstuck > Reset Exercise > Reset Exercise (click the link)”

Hi all, I’m experiencing the same issue with the blank embedded web browser pane on two different courses (ASP.NET and Learn R)

  • Safari (macOS)
  • Edge (macOS)
  • Firefox (macOS)
  • Edge (Windows 11)

I’ve taken the same troubleshooting steps on all browsers (refresh pane, browser, disable extension, clear cookies) but it doesn’t help. When I was working through Learn R last week the embedded web browser pane worked fine and rendered the R notebook, but now it’s blank when I access the same lessons.
Given that the issue is spread across at least three different courses and multiple different configurations is this an issue with Codecademy’s end rather than something we can debug ourselves?

I have not got it sorted yet :frowning:

Going to try and see if “Reset Exercise” fixes it :+1:

I haven’t tried that yet! Will that reset my progress for the whole lesson, or just that exercise?

“Get Unstuck > Reset Exercise > Reset Exercise (click the link)”

will just reset the exercise.

DON’T go the course main page and reset progress. That will reset whole course.

1 Like

Ok I have a strange update. I went to go Reset the Exercise as @mtrtmk suggested, and when I pulled up the page it is working…

I am at work and on a different network though (not sure if that matters). I will re-test this when I get home.

1 Like