Bash command not recognized


#1

I started the Associations I project and created a new Rails application. After that, I was not able to use any bash commands. (I tried to upload a screendump, but that also fails: it keeps saying 'Uploading 100%'.) The files have been created, I can see them in the editor, but I cannot change to the project directory.

This happened before in another project. Using MacOS 10.11.6 with Firefox 53.0 (64-bits).
Any suggestions?


#2

Hi @ctammes,

Could you please post a link to the exercise and a list of at least some of the commands you've tried?

Switching browsers may help, could you try that?


#3

This happened at https://www.codecademy.com/courses/learn-rails/lessons/one-many/exercises/one-many-adding-data?action=lesson_resume excercise 1/9.

Then at 5/9 I had to enter code in app/views/tags in index.html.erb and show.html.erb. I opened index file and the code was colored and I entered the text. Then I opened the show file, but the text was grey and the code I entered was not accepted: an error message telling that show.html.erb could not be found. I reset the project and logged out and in several times and then, all of a sudden, there where two files show.html.erb in the same directory. I opened them both and one had only grey text as before and the other the usual colored text. I deleted the one with the grey text and then the file was accepted.

I don't know what is happening, but sometimes the system doesn't seem very stable. I often get weird behaviour and then, 10 minutes later, everything works again.


#5

@ctammes I'm having the same problem, but I think it's less of a bug and more just unclear design. Codecademy seems to be restricting commands to only the subset necessary for the exercise. So, if you run bundle install, it works with no problems, but ls or pwd will both fail since they weren't considered necessary.


#6

Yes, maybe you are right. I just spent 10 minutes to find out that a Rails text had to be within double quotes instead of single to be accepted, while single quotes are valid as far as I know.

Some exercises have a Save button and they seem to be more flexible, others have a Run button and they seem to be very strict. I'll try to get used to it.


#7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.