Bad Aim system's Bug?


#1



https://www.codecademy.com/courses/python-beginner-en-4XuFm/1/3?curriculum_id=4f89dab3d788890003000096


Traceback (most recent call last):
File "python/cli_runner.py", line 152, in module


from random import randint

board = []

for x in range(0, 5):
    board.append(["O"] * 5)

def print_board(board):
    for row in board:
        print (" ".join(row))

print_board(board)

def random_row(board):
    return randint(0, len(board) - 1)

def random_col(board):
    return randint(0, len(board[0]) - 1)

ship_row = random_row(board)
ship_col = random_col(board)
guess_row = int(raw_input("Guess Row:"))
guess_col = int(raw_input("Guess Col:"))

print ship_row
print ship_col

# Write your code below!
if guess_row == ship_row and guess_col == ship_col:
    print "Congratulations! You sank my battleship!"
else:
    if guess_row not in range(0,5) or guess_col not in range(0,5):
        print "Oops, that's not even in the ocean."
    elif board[guess_row][guess_col] == 'X':
        print "You have guessed already!"
    else:
        print "You missed my battleship!"
        board[guess_row][guess_col] = 'X'
    print_board(board)


#2

this error message usually mean you use a character which has no ascii value. This could be a colon, or another character which is not valid. This kind of mistakes are the worst to find


#3

what does ascii value mean?


#4

wikipedia - ascii


#5

Thank you very much!!


#6

return randint(0, len(board[0]) - 1)...this line is wrong, it should be (len(board)-1)


#7

actually, no? What if you want to have a 8x6 board for example, then (len(board)-1) could give values which are not on the board.


#8

no, you should get the counts of col, so you must get one of the rows. board[0] or ,1 ,2,3,4 just have a think.


#9

@systemrunner13716, absolutely right. Good explanation :slight_smile:


#10

The best wayto learn is to let others understand their own meaning。
Happy coding :grin:


#11

yeep, I finally find the mistake . actually you are right!
when i type again, it really works.


#12

Did you also figure out which character/symbol it was?

Not very important, most important is that you solved it :slight_smile:


#13

I only find which line is the mistake.

if guess_row not in range(0,5) or guess_col not in range(0,5):

but I cann't figure out which character, maybe a space " " or ":"。


#14

i would suspect the colon. I replaced the colon (:) and it worked


#15

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.