Appointment planner - npm start doesn't work

Hi guys,

I want to start Appointment planner project, but I’m stuck at the very first step. It says in terminal (I’m using gitbash on windows instead) just cd to the root directory and run npm install until this step everything looks good, then I need to run “npm start” but I get this error message:

npm ERR! missing script: start

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\asus\AppData\Roaming\npm-cache_logs\2021-08-14T07_08_43_344Z-debug.log

any ideas what the problem is?
by the way i tried to change start scripts part on the package.json file based on my searches in stackoverflow, but nothing worked :frowning: it’s like this now: “start”: “react-scripts start”

here is the link to the project:

Hi @tabassoml
I installed that project on a Mac, but that shouldn’t make much of a difference.
You don’t need to change the command. ‘Command not found’ usually either means that the node modules aren’t installed or you’re still in the wrong directory. Two things you can do to double check:

  1. After npm install: Do you have a folder named node_modules in the same directory as the package.json file?
  2. After cd: When running pwd in the terminal, does it log the directory in which your package.json is located?

Thanks a lot for your answer, the problem was solved, your right, I wasn’t in the right directory and I needed to go one step down into the folders to be in the same one with package.json and node.modules.

thanks a lot again :slight_smile:

1 Like

Hi I am also having this issue. I ran npm_install and the nodes_modules directory and package.json file are in the same directory. I am in the correct folder. I am currently getting an [ERR_PACKAGE_PATH_NOT_EXPORTED] error.

Just in case anyone else gets this error - it is probably newer node version. My advice would be to install nvm and then install node 16.19.0. Everything should be working fine.