App wont load after starting rails server | Heroku Toolbelt not installed


#1

Created the new app
Generated the Pages controller
defined the welcome action
made the welcome page the root route
populated “welcome.html.erb” and “pages.scss” with some beautiful html and css code
rails s -p 4001…

“Not Found”

The terminal says that the server is running, yet when I go to load the page…
“Not Found”

|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
Another issue I’m having is that this is actually my second try with this project!
The first go around all of this worked, and I had a nice little one page app.
Then I pushed the code to github… NEATOOO!!!
Okay, let’s launch this baby on Heroku!

Heroku login
Bash: Heroku: command not found

visits how to launch to heroku
“1. Create a new Heroku account. CHECK! Already did that!
2. Install the Heroku Toolbelt on your computer. The Heroku Toolbelt is installed by default in new Codecademy workspaces.

So it should already be installed?

But it isn’t?

gem install heroku

done…

heroku login
install the heroku CLI from https://cli.heroku.com

Tries and fails for about an hour

This seems like some bugs. This is really frustrating and time consuming and now I’m spending way too long writing about it instead of actually building the cool thing.

As a pro member, a glitch like this, that completely de’rails’ the project, makes me consider unsubscribing the most.

Is anyone else having these or similar problems? Has anyone found solutions or know anything about this? Thanks


#2

Hi @trevorhauck,

I’m sorry you’re running into these issues and am happy to help, but have you tried contacting an advisor through the chat button in the bottom right corner? They can usually help you find the problem faster.


#3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.