Another sqlite3 version issue

I’m having an issue where sqlite3 isn’t working as expected. In the previous project I had similar issues with it and tried a number of fixes before one worked. I think maybe one of those fixes locked my version on 3.31.1. Below is what I’m seeing in cmd when typing “sqlite3 --version”…
List of things I have tried:

  1. uninstalling and reinstalling sqlite3 using npm and sudo at the specific version and normally. Both have worked, though still within the project it reads it’s at version 3.31.1.
  2. regular npm install with and without -c and -ci commands so as not to alter json.package information.
  3. using nvm, using new versions of node to see if that would allow it to change… idk, didn’t work.
  4. altering json.package and using npm install to ensure it wasn’t because of that…

package.json for the project is at version 5.0.0 now so I must have messed something up on a root level, I think. Any advice or ideas?

Another question… in json.package it reads that both sqlite3 and sqlite versions are set for this project. Is this an either/or thing or should I be using both for some reason? what is the difference?

Link to the expresso project here.
extra info:
I am using a windows PC with WSL in an Ubuntu distro. Perhaps it has something to do with that or maybe that affects how to approach the problem. Just thought it might help.


version output

sqlite3 --version
3.31.1 2020-01-27 19:55:54 3bfa9cc97da10598521b342961df8f5f68c7388fa117345eeb516eaa837balt1