Adopt a pet Error

I can not get my start code running… Can someone please help understanding this error?

Compiled with problems:X

ERROR in ./src/assets/logo.svg

Module build failed (from ./node_modules/file-loader/dist/cjs.js):
Error: error:0308010C:digital envelope routines::unsupported
at new Hash (node:internal/crypto/hash:67:19)
at Object.createHash (node:crypto:135:10)
at getHashDigest (/home/user/Desktop/misc/code-cademy/react-router/adopt-a-pet-starter/node_modules/loader-utils/lib/getHashDigest.js:46:34)
at /home/user/Desktop/misc/code-cademy/react-router/adopt-a-pet-starter/node_modules/loader-utils/lib/interpolateName.js:113:11
at String.replace ()
at interpolateName (/home/user/Desktop/misc/code-cademy/react-router/adopt-a-pet-starter/node_modules/loader-utils/lib/interpolateName.js:110:8)
at Object.loader (/home/user/Desktop/misc/code-cademy/react-router/adopt-a-pet-starter/node_modules/file-loader/dist/index.js:29:48)

Can we have your code and a link to the project?

link the project

https://www.codecademy.com/paths/front-end-engineer-career-path/tracks/fecp-22-react-part-ii/modules/wdcp-22-react-router/projects/pet-adoption-website

i havent added any code yet.

i just run npm start. I have got the follwing.

added 1 package, changed 1 package, and audited 1409 packages in 4s

185 packages are looking for funding
run npm fund for details

6 moderate severity vulnerabilities

To address all issues (including breaking changes), run:
npm audit fix --force

Run npm audit for details.

then i run npm start. I have got the following

ERROR in ./src/assets/logo.svg
Module build failed (from ./node_modules/file-loader/dist/cjs.js):
Error: error:0308010C:digital envelope routines::unsupported
at new Hash (node:internal/crypto/hash:67:19)
at Object.createHash (node:crypto:135:10)
at getHashDigest (/home/user/Desktop/misc/code-cademy/react-router/adopt-a-pet-starter/node_modules/loader-utils/lib/getHashDigest.js:46:34)
at /home/user/Desktop/misc/code-cademy/react-router/adopt-a-pet-starter/node_modules/loader-utils/lib/interpolateName.js:113:11
at String.replace ()
at interpolateName (/home/user/Desktop/misc/code-cademy/react-router/adopt-a-pet-starter/node_modules/loader-utils/lib/interpolateName.js:110:8)
at Object.loader (/home/user/Desktop/misc/code-cademy/react-router/adopt-a-pet-starter/node_modules/file-loader/dist/index.js:29:48)

webpack compiled with 1 error

Did you run npm install before npm start?

I had the same issue just today. I kept on using the commands:

‘npm install --save [email protected]’ and updating the install with ‘npm audit fix --force’

After a few tries it somehow worked. Best of luck!