8/21 Why Procs? error: private method `select' called for 4.1:Float


#1

Here is my code below, is run correctly and allows me to move on the next section however, I received this error in the console "private method `select' called for 4.1:Float"

group_1 = [4.1, 5.5, 3.2, 3.3, 6.1, 3.9, 4.7]
group_2 = [7.0, 3.8, 6.2, 6.1, 4.4, 4.9, 3.0]
group_3 = [5.5, 5.1, 3.9, 4.3, 4.9, 3.2, 3.2]

Complete this as a new Proc
over_4_feet = Proc.new {|h|h.select >= 4.0}

Change these three so that they use your new over_4_feet Proc
canride_1 = group_1.select(&over_4_feet)
canride_2 = group_2.select(&over_4_feet)
canride_3 = group_3.select(&over_4_feet)


#2

Should be,

{ |height| height >=4 }