7/7 Everything goes fine except the Answer Checker :(


#1

Hello! This is my code: http://pastebin.com/LYYhahvR, I think my code is correct but when I click Save & Submit:

It looks like 'LOL=>Laughoutloud!' is part of $myArray, but it wasn't printed to the page!

Which makes no sense :frowning:

Thanks in Advance!


#2

I had the same problem and change my code
from: $myArray = array('dog'=>'chow', 'cat'=>'calico', 'snake'=>'copper head');
to: $myArray = array('dog'=>'chow',
'cat'=>'calico',
'snake'=>'copper head');

and then it worked i guess its how the site checks your code.
so you should change $myArray = array("LOL" => "Laugh out loud!", "FYI" => "For your information");
to $myArray = array("LOL" => "Laugh out loud!",
"FYI" => "For your information");
and see if that fixes the error


#3

Great! It works perfectly! Luciano Fiore should fix this :smile:


#4

I definitely can confirm, its some part of the answer checker thats broken for this answer. I had 2 elements on one line and it didnt work until i put the next element on a new lone :sweat_smile:.


#5

I agree. I think these are known and non rare bugs.


#6

Thanks man!! I couldn't figure out what was wrong with it. Just pressing enter there fixed it.


#7

Amazing!It‘s interesting!But why?


#8

Notice that this is the first question where a link to paid accounts is included in the help section.


#9

Thank you so much...I was so tired of my answers not being accepted, I thought I was leaving without my badges...I'm so happy now...I'm going to get see if my other "environment" (submit button) issue can be resolved so easily also...great help!