6.cp ll I dont get it


#1

When I do each instruction the box checked but the result I get is not similar to what it said it would.Can anyone help with that?
This is my code:

$ cd ../../comedy
bash: cd: ../../comedy: No such file or directory
$ mkdir shrek.txt
$ touch shrek.txt
$ cp * satire/
cp: target 'satire/' is not a directory
$ cd satire
bash: cd: satire: No such file or directory
$ ls
action  comedy  drama  genres.txt  shrek.txt
$ cd ../../action/
bash: cd: ../../action/: No such file or directory
$ cp m*.txt scifi
cp: cannot stat 'm*.txt': No such file or directory
$ cd scifi
bash: cd: scifi: No such file or directory
$ ls
action  comedy  drama  genres.txt  shrek.txt

#2

It looks like you weren't in the directory that the lesson assumed you'd be in. Right from the first line you're getting directory errors. ../ makes you go up a directory in your tree but its relative to where you are at that moment. Two very useful commands you can use are ls to LisT the files and directories in your current directory and pwd to Print Working Directory to ensure you're in the directory you should be.

From the above code it looks like you were told to cd into 'comedy' but your relative tree navigation did not find a comedy directory two dirs up. You kept on performing the tasks and I guess the Codecademy Command Line environment was just tracking your inputs and NOT what the results of your actions were. If you reset the lesson and make sure you're in the comedy directory after your first navigation then the rest should work well.

Except mkdir shrek.txt, a directory does not have an extension. But it looks like you figured that out by touching right after.


#3

thank you so much :blush:


#4

It didn't work for me I keep pressing reset and it won't open the terminal after I reset it. I even tried refreshing the page but it would only take me back to the problem with the first instruction checked out.


#5

If you enter pwd and then ls what directory are you in and what files do you see there?


#6

$ ls
action comedy drama genres.txt
$ pwd
/home/ccuser/workspace/movies


#7

So then can you cd into comedy to continue?

$ cd comedy

#8

$ ls
satire  shrek.txt  slapstick  the-office.txt
$ pwd
/home/ccuser/workspace/movies/comedy

Still doesn't let me continue.


#9

What is the next pending instruction on the left?


#10

It says "In this directory, create a new file named shrek.txt. (Here's a hint on how to do this.)"


#11

It looks like that's already done, but you can try this:

$ rm shrek.txt
$ touch shrek.txt

The first command will delete the existing file, the second will remake it. Let me know if this passes you to the next step.


#12

Thank you. Touch fixed it.


#13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.