6.3 - Find a destination - bugged?


#1

So... I was going through the exercise all right when it came the time to:

"
Then in the Destinations controller, set up the show action. Use params to find a destination by id, and save it in @destination

"

And my code looks like this but the lesson won't proceed.

class DestinationsController < ApplicationController
  def show
     @destination = Destination.find(params[:id])
  end
end

Am I forgetting something silly?

Exercise Link


#2

Hi @cloudpro89127,

Your code looks fine to me. What's the error message you're getting?


#3

I'm not even getting any messages. The icon on the task just changes to Red X and "good luck figuring out why".


#4

@cloudpro89127 Hm... could you try refreshing the page and/or switching browsers?


#5

I'd tried reloading a few times already, to no avail.

So the browser I normally use is Chromium (currently v. 52.0.2743.116 (64))
Konqueror is told it's not supported
I've tried loading the exercise in Firefox (48.0.2-1) and also didn't work.
Running all these under Arch Linux. I've completed the entire Ruby course under this setup and the Rails course up until this exercise. Don't think it's an update thing either cause I'd been working for quite a while in the day this problem showed up. If it was I'd expect the issue to have manifested when I first began working


#7

@cloudpro89127 Sorry for the delay responding!

I've seen a bunch of reports of people being failed on exercises for no apparent reason in the Rails course this past day or two, so I think it's a bug on Codecademy's end. My best suggestion is for you to file a bug report with them, then wait a few days and come back to the course :confused:


#8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.