6/15 working but not displaying anything


#1

Hi!

My code is:

$(document).ready(function() {
SC.get('/tracks/293', function(track) {
SC.oEmbed(
track.permalink_url,
document.getElementById('player')
);
});
});

It says Congratulations!... but nothing is displayed in the preview like it should. And the message under the console reads: "Script error."
Does anyone know what's going on?
I know that these are a little new, and still have some bugs, but I'm hoping someone knows what's going on :confused:


#2

Hello! I've noticed the whole SoundCloud API program glitching out to be honest. I've typed in incorrect code and it's marked it correct and I've typed in correct code and it's marked it wrong. I also passed this exercise correctly with the display in the corner being blank and I got an error saying "Uncaught SyntaxError: Unexpected token ILLEGAL" however it passed. So my guess is that it's just a bug with the program and it has many loop holes which is why the code is passing.


#3

Same problem here, I can't really see what i'm doing cause the preview is always empty.. :-/


#4

It is definitely a bug from the course... There's nothing for us to do but hope that the creators of this course fix it. I think everybody has this problem.


#5

It is February 29. and it is still note "Script error" staying under preview screen together with code passing, without showing any result. It is not fixed and who knows will it be in the future. Small amount of people go through this course so no one cares about it I guess.


#6

Still the same. My code is "correct" albeit a script error alert. And my preview is still a blank slate. Moving on.


#7

Try going to http://soundcloud.com/you/apps and registering an app. Then replace YOUR_CLIENT_ID in SC.initialize:

client_id: 'YOUR_CLIENT_ID'

with the client ID you get from SoundCloud.

This resolved the empty preview issue for me.