5/11 code works but I can't submit


#1

Hi, it seems to me I am doing everything right. The code works as it should, but I get a red square in the excercise and I can’t move to the next one. Am I not seing sth? Help!


#2

Hi @coreslayer25712,

Prior to testing your code for an invalid word, did you test it for a word that contains only letters? You might need to do that first in order to pass.


#3

Hey @appylpye!

Hm… I thought this is what I’m doing here:
and original.isalpha()

The current code only checks if the string is not empty and if it only contains letters.


#4

Ah, now I get what you meant: I tested this for a word that contains only letter and it still doesn’t want to get me through.


#5

Does it give you an error message? If so, what is it?


#6

Unfortunately no error message… also, when I finally clicked “get code”, it looks exactly the same as mine. When I run the code it also gives me a red square but no error message.

Might this be a bug?


#7

It may be a bug, but there could be a way to get around it. First, try refreshing the page and running the program again.

Following is a screen capture from my computer …

In the console on the right portion of the screen, alphabet was entered, and it was output. What do you see in your console after entering a word? Is there any output message in addition to the original word?

If the problem persists, could you copy and paste your actual code, so that we could run it? Be sure to format the code when you post it. See Quick Tips for Writing Good Posts if you encounter any difficulty with the formatting.


#8

Works perfectly now, but I have no idea what caused it :slight_smile: I tried refreshing the page and it didn’t work, now it does. Thanks!


#9

It appears to be a bug event with a happy ending. :grin:


#10