5.1 preview your site locally


#1

Hi
I can't understand what am I supposed to do in this exercise, I tried every cd command but nothing happen...
Help me please ! :)


#2

I don't know what you're supposed to do, but the instructions are to go into the site's directory.
That might not be the same as your home directory, which is what you get when you run cd with no arguments.


#3

i need help on this to?


#4

Then perhaps you'll want to ask about it!

I've explained what I think is wrong in the screenshot, if that's not sufficient you'll have to keep asking.


#5

2 posts were split to a new topic: 5.1 I can't figure this out


#7

2 posts were split to a new topic: 5.1 It keeps saying "Navigate to personal-website"


#8

Hi,

It sounds like you know what to do. I can't seem to progress through the page even though I've got the Jekyll site to run.

I've changed the directory to personal-website:
"cd /home/ccuser/workspace/daw/personal-website"
and then ran
"Jekyll serve"

But the error message still keeps on telling me to use "cd" to navigate to my personal-website directory...

Is the syntax that I'm using incorrect?


#9

I think that checkpoint ignores what actually happens and just looks at what you entered.

Try cd personal-website, shouldn't even matter if that's a useful command from your current working directory, you just need to have entered that.


#10

Thanks mate.

It's interesting: I get the green ticks now (which is good) but the code actually doesn't load the locally host website... Anyway thanks


#11

Yeah, if you just enter the right commands but in the wrong situations or it fails for some other reason..

You should be getting output similar to this:

$ jekyll serve
Configuration file: /home/ccuser/workspace/daw/personal-website/_config.yml
            Source: /home/ccuser/workspace/daw/personal-website
       Destination: /home/ccuser/workspace/daw/personal-website/_site
 Incremental build: disabled. Enable with --incremental
      Generating...
                    done in 0.248 seconds.
 Auto-regeneration: enabled for '/home/ccuser/workspace/daw/personal-website'
Configuration file: /home/ccuser/workspace/daw/personal-website/_config.yml
    Server address: http://0.0.0.0:4000/
  Server running... press ctrl-c to stop.

#12

Wow you are good at this!


#13

A post was split to a new topic: Need help with viewing site locally


#14

I think I have a big problem :frowning: because mine says this:
$ jekyll serve
Configuration file: none
Source: /home/ccuser
Destination: /home/ccuser/_site
Incremental build: disabled. Enable with --incremental
Generating...
Build Warning: Layout 'post' requested in workspace/daw/personal-website/_posts/2016-05-18-welcome-to-jekyll.markdown does not exist.
Liquid Exception: Included file '_includes/icon-github.html' not found in workspace/daw/personal-website/about.md
jekyll 3.1.3 | Error: Included file '_includes/icon-github.html' not found
$ cd personal-website
bash: cd: personal-website: No such file or directory

Something is wrong :frowning: Thanks. You are good!


#15

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.