4.Organize with partials


#1




Codecademy is giving me the error 'Did you import the variables in main.scss?' and sometimes about border top value that is wrong.
could you please send me the code inside _variables.scss and correct my answer?

@import url(https://fonts.googleapis.com/css?family=Pacifico); //CSS import
@import "helper/placeholders";
@import "helper/mixins";
@import "helper/variables";

.absolute{
      position: absolute
    }

h1 {
  font-family: Roboto, sans-serif;
}

.banner {
  font-family: 'Pacifico', cursive;
  height: 400px;
  background-image: url($lemonade-banner);
  border: {
    top: $border;
    bottom: $border;
  } 

  .slogan {
    background-color: $translucent-white;
    border: 4px solid black;
    top: 200px;
    left: 25%;
    line-height: 200px;
    @include dimensions
      (50%,200px);
    @extend .absolute;

    
    
    span {
      width: 40%;
      left: 30%;
      @extend .absolute;
    }
  }
}

.container {
  font-family: 'Pacifico', cursive;

  .icon {
    display: inline-block;
    margin: 2%;
    border: $border;
    @include dimensions(300px, 300px);
  }
}

#2

The only thing it asks you to do in this lesson is to add this line:

@import "helper/variables";

You seem to have it, so check that you edited nothing else.


#3

i didn't edit anything else and it seems it's not really importing anything. i tried changing some values in _variables.scss but nothing is happenning


#4

Reset _variables.scss to it's original code. It has not asked you to change anything in there, which is probably the source of the problem.


#5

when i try to reset it codecademy just loses connection


#6

Okay. Here's the original code, go ahead and paste it into it:

$translucent-white: rgba(255,255,255,0.3);
$lemonade-banner: "https://s3.amazonaws.com/codecademy-content/courses/Sass/lemonade2.png";
$border: 4px solid black;

#7

Thank you for the code but the problem remains


#8

Hm. Sounds like a bug... Try reporting it. Sorry about that.


#9

I will. Thank you. btw im amazed by how many courses u finished


#10

Try it in a different browser...I was having the same issue, but tried it in Opera, and what-do-you-know! It works


#11

Looks like this is a reoccurring bug. I'm having the exact same issue. What browser where you originally experiencing the bug in pycoder19497? Similarly, have you been able to correct the issue in another browser?

I'm currently working on this course in Safari version 10.0.1 (11602.2.14.0.7) and experiencing the same bug.

Alternatively, I did read one post about this bug where the o.p. was able to move on after copy and pasting something into the variables file. Unfortunately they didn't say what and their topic is now 'Closed'.


#12

Just tried the same page again with exactly my same input at the top of main.scss,

@import "helper/variables";

just using Chrome version 55.0.2883.87 m rather than my previous attempts on Safari.

Looks like it could be a bug based on browsers, at least for me Chrome fixes the issue for now (Y) :slight_smile:


#13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.