4/9 Step 2 Error HELP!


#1

Hello everyone.
So as the title states I am on 4/9 and step 2 of associations I, and am having a weird error.
Step 2 tells me to "add a new route that maps requests to /tags to the Tags controller's index action."
So this is my routes.rb code:

Rails.application.routes.draw do
	
  get '/tags' => 'tags#index'
  
end

I hit run and I get this message:
Oops! The test returned an error. Maybe you have a syntax error, or a typo.

/home/ccuser/.gem/ruby/2.3.0/gems/activesupport-4.1.1/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now

Circular argument reference?!?!?!
Really confused guys! :sweat:
(and yes, I have set up the tags controller)
Thanks in advance!


#2

Please paste your tags_controller.rb.


#3

Hi @sgt.schultz,

From a quick search, it seems that perhaps your Ruby version doesn't work with this Rails version:

Could you tell us what output the commands ruby -v and rails -v in the terminal produce?


#4

Thanks for the reply @zystvan,

ruby -v

produces "ruby 2.3.1p112 (2016-04-26) [x86_64-linux-gnu]"

rails -v

told me that I didn't have gems installed!?! :confused:
Just ran "bundle install" again and error still occurs...

PS: For anybody who thinks I didn't do this at the start when it told me, I did. I've been following rails step-by-step and now it says it isn't installed?


#5

Can you access your Gemfile and tell us what's the specified version there?


#6

Straight from the Gemfile:

gem 'rails', '4.1.1'

#7

@sgt.schultz Could you post a screenshot and a link to the exercise so I can test if I'm also getting the error? Sorry for the inconvenience this is.


#8

Link to exercise: https://www.codecademy.com/courses/learn-rails/lessons/one-many/exercises/one-many-display-tags?action=lesson_resume

As you can see, the error message has since changed?!

Thanks for all the help!

(ps: Hello from another homeschooler :grin:)


#9

@sgt.schultz I can't reproduce your error (I'm unable to reset the exercise to actually test, though), so I can't really help you much :confused:

It looks like that error has something to do with the i18n Gem, but since bundle install doesn't work I'm not sure of much you could do other than verify that it is in your Gemfile.

Are you able to reset the exercise and start from scratch, maybe?

Sorry I can't be more helpful :sweat_smile:


#10

Thanks for your replies. Just reset and tried again...no luck.

Really want to continue so I will keep working on it.


#11

Update: Reset yet another time, went through it and for some reason it works now!
Pretty sure the ONLY thing I did different was not put any whitespace in the routes.rb file.
Thanks for all the help guys!

(Feel free to close the thread b/c I don't think I can.)


#12

This topic is solved.