4.15 "'int' object is not callable" error - French version -


#1

Hi all,
I'm stuck on this exercise with the famous error int'object is not callable. I've applied all solutions I found in the forum, but none worked for me even if the result of the function is good. Here's my code, any hint? Thanks in advance, Laurent.

link to exercise


#2

A link to the exercise would be helpful.


#3

right, I just add it :flushed:
Laurent.


#4

You've likely assigned a number to one of the names that you're calling (str or int, both are supposed to refer to classes). Refresh page to reset the environment.

You can print out those names before you refresh to see for yourself that they don't have the values that they should have:

print str, int

Normally it'll say that they are classes/types

...

Or at least that's what I'd want to say. Just noticed that you're getting a result without any errors. Yeah, that link would be useful.


#5

Hi,
for the link I did edit my first post, you can find it under the screenshot.


#6

Yeah I see it now.

There's a pretty blatant bug in the submission test, perhaps I can figure out a way to pass it.


#7

When I do print str,int I obtain:
I tried to refresh and even logout/login, but I still have the same error.


#8

Add this at the very end of your code. It'll crash the submission test and just pass you

del somme_chiffre
NameError = "just about anything other than what it's supposed to be"

#9

When I do print str,int I obtain:"<"type 'str'>"<"type'int'>
I tried to refresh and even logout/login, but I still have the same error.


#10

When I add the 2 lines I now have the error:


#11

Contrary to your screenshot, I think you did:

del somme_chiffre()

Note how it says "can't delete function call"
What you're deleting is the function, so no ()'s

Your code in the screenshot looks just like I mean it should be, but I think you ran something else.


#12

Hi Ionathan, right, I've tried with ()'s because I had the following error: I've logged out/logged in again and I now have the error:


#13

Oh. Interesting.

Also add:

Exception = "somebody should get around to fixing this..."


#14

:tada: it works now!
Thanks Ionathan,
Laurent.


#15

I'm sorry you had to go through that. Shame on codecademy.

I have to suggest doing the English version over the translated ones, if it's an option. The English track "only" has one exercise that is broken to this degree.


#16

Well, The tool is great, they should have a chance to improve. I hope they have reports about the content in the help forums.

About the English version, the language is not an issue for me, except that I don't want to start from scratch again...
Laurent.


#17

3 posts were split to a new topic: Does not work


#18

Hi,
Thanks for this ! I'm french too and i have the same error yesterday, i search my error in my code during all the day...It's a bug :confused: But now i can continue too.


#19

Hello,
I got the same problem.
First I did the code with str() and I got the error message.
So I tested with % and // and finally I got the same error message...
So now I know that it's not me :slight_smile:
Thanks, now I can continue.
Bye

By the way there is error with the link in the left bottom to access the forum...
and sometimes with accents in some exercises but eventually found a solution