[#322] JavaScript -- Introduction to Objects I -- exercise 11 -- passes but isn't getting a checkmark

bug-composer
bug-reported

#1

The problem page https://www.codecademy.com/courses/spencer-sandbox/1/6?curriculum_id=506324b3a7dffd00020bf661

my code

// help us make snoopy using literal notation
// Remember snoopy is a "beagle" and is 10 years old.
var snoopy = {
species: "beagle",
age: 10
};

// help make buddy using constructor notation
// buddy is a "golden retriever" and is 5 years old
var buddy = new Object();
buddy.species = "golden retriever";
buddy.age = 5;


11. Putting it all together is bugged
#2

I'm not quite sure what this means. Could you try again to explain the problem you are facing?


#3

So when I hit submit, it turns green and says "good job,move on" (not the exact phrase). Then the next page loads but I cannot hit submit. The gear just spins continuously unless I refresh the page. If I click the menu in the bottom left that brings up the numbered steps/problems there is no check mark showing I completed #11.


#4

On 12. after you refresh, are you then able to complete the exercise?


#5

Yes if I refresh 12 I am able to complete 12 but it shows 11 as incomplete. I have completed all of Objects I but it still shows 11 as incomplete for some reason and will not give me the credit for completing it.


#6

Are you able to use a different browser just to try to complete that one exercise?


#7

I have tried on Firefox and Chrome and it will still not work. I have even tried on a separate computer.


#8

When I check developer tools the console shows this when I submit.

POST common-db66576….js:1 https://www.codecademy.com/composer/4ef0155c26009d0003000f5b/checkpoint/4f0209a5840853000300a9cd/submit?authentication_token=mRg4xoiF0ctxEOjDFQ2U 500 (Internal Server Error)


#9

There are a few things that I need before I can submit a bug report ticket.

Could I get two screenshots from you please? Make them of your whole web browser.

  1. Exercise 11 showing that your code passes
  2. The list of all the courses with 11. missing its checkmark

Also:

  • your operating system?
  • are you on a home/school/work network?
  • do you have an ad blocker on?

#10


Ubuntu 14.04 LTS
Home netowork
no adblock


#11

dev tools console log shows

Event
Uncaught [object Event]
POST https://www.codecademy.com/composer/4ef0155c26009d0003000f5b/checkpoint/4f0209a5840853000300a9cd/submit?authentication_token=mRg4xoiF0ctxEOjDFQ2U 500 (Internal Server Error)


#12

Thank you for all of the details. A bug report has been submitted. These things often take a long time to resolve. I will post any action on the report here.


#13

A post was split to a new topic: JavaScript – Introduction to Objects I – exercise 11


#14

Hi Keith,

I've just heard back on this one. They've had a look. This course is on the list to be migrated soon and they've decided not to spend time on this old version.

That is sort of good news and bad news together. :slight_smile:


#15

Ok. Thanks for the response. Any clue on a rough timeline for the new migration? The 99% when I know its completed is driving me crazy.


#16

I can understand that! I do not have any clues about a timeline though.