#3 One Selector Rule Them All problem


#1

Hi there, I am trying to submit my lesson here but it always prompts the following:

"Oops, try again. Make sure that you use the universal selector * to give a border 1px wide.".

The funny thing is it seems like my code was written properly.
Here's the instruction:
Go ahead and use the universal selector to put a 1px dashed #3A5FCD border around every element on the page.

Here is my CSS code:

*{
border: 1px dashed #3A5FCD;
}

Can anyone point out what the issue is with my code? Thanks in advance.


#2

@courseace04270,

There's nothing wrong with your code (I tripled checked)

Maybe it has to do with something in your index.html part, just see if your code in that part matches this --->

<!DOCTYPE html>
<html>
	<head>
		<link type="text/css" rel="stylesheet" href="stylesheet.css"/>
		<title>Result</title>
	</head>
	<body>
		<h3>Boxes within boxes!</h3>
		<div>
			<p>Paragraph One</p>
		</div>
		<div>
			<p>Paragraph Two</p>
		</div>
		<div>
			<p>Paragraph Three</p>
		</div>
	</body>
</html>

#3

my code is exatly like yours and the results are correct and I still can't save and submit.
This has happened on a few occasions, I just think it's a bug in the program


#4

Hi Christopher and @wlivesey,

Have you tried refreshing the page and switching browsers? I tried the CSS code given, and passed without a problem using Firefox.


#5

I compared and it was identical. I also tried to copy paste your code into the .html page to make sure and still nothing.

It`s weird because the result page shows the blue borders correctly..

I`ll try switching browser like below.


#6

Thank you Zystvan, I switched from Chrome to Firefox as you advised and it worked.

However, that means there is a bug on the Chrome side :frowning:

Well I`ll still check as solved, thank you !


#7

I'm running this in Firefox and it still fails. I've even closed and re-opened Firefox. Here's the code:
* {
border: 1px dashed #3A5FCD;
}


#8

Have the same problem, in Safari - dosent work
Add: ok, that was my fault )) I made extra gap between '1' and 'px' ))


#9