3. Controller lesson3/7


#1

I can't work out what I'm doing wrong to create a route.
Can anybody help?
Thanks


#2

Hmm, that's weird... It looks right in my eyes. :confused:
It would be better if you showed us everything and not just the code and the instructions, i'd like to see the error message..

1) Are you sure you have an "end" in the bottom of the code
2) Have you tried refreshing the page?
3) Have you tried to reset the excersise and re-doing it? (I think it only resets 3/7 and not everything.)
4) If still not working, re-create the controller and then try routing it again.

Best of luck, and please update us! Would love to see if you fixed it.. And it might help future coders that has the same issue.. :grin:


#3

Hi Thanks for your response. There is no error message. I wonder if the system is even registering the code....

Yes there is an end
refreshing doesn't help
How do I reset the exercise?
How do I remove the controller to re-create it? I've tried using destroy and rm......

Thanks


#4

Greetings.

You reset your excersise by clicking help > reset and then you refresh your browser..
Take a picture of your whole browser please, it's very hard to help you by just seeing it denying you to proceed...

best regards.


#5

Hi everyone,

I had the same problem and i fixed it just now, as @melkerx said, by resetting the exercise.
Also, the / in get '/messages' => 'messages#index' is unnecessary. You could just write get 'messages' => 'messages#index'

I hope this helped in some way.


#6

Hi,

I was stucking the same way and resetting work for me too.

Good Luck all.


#7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.