3/7 won't let me past but it should?


#1


Just look at the pic
I did it correctly and it didn't work so I went back out and restarted it, made sure I was in the correct directory and tried to run it again and it won't recognize that I'm running git. wtf?




#2

You're not in the right directory, running cd without arguments takes you to your home dir which is not where they drop you off
You could refresh the page and start looking from there with just ls, or you could search your home dir for directories named personal-website (you probably have one in the correct location as well)
find ~ -type d -name personal-website
That second argument is a tilde, you can also use $HOME or /home/ccuser for that argument


#3

OMG Thank you so much! I didn't realize it needed to be in a specific directory. I've had it in that directory before but I had issues where I think a file got changed so I tried to create another jekyll file in another directory and assumed it would work as long as I was able to get to it just like shown above.

You rock! Thank you. (Though, you'll laugh about this I didn't have it in the correct directory but rather the one shown above and another random one xD haaaa. Go figure)


#4

So did you solve it?


#5

Yes. I had to go back to the first section and create the jekyll in the correct directory under the correct name as explained in that lesson. Once I did that I was able to come back to this lesson and cd to the correct place and it allowed me forward.


#6

or what I did, is to run "git init personal-website"
without the ".git" at the end.


#7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.