3/7 Using Arrays as Maps. There is a bug?

php

#1

my code meets exactly as the question asked. It's a bug? where I wrong?

when I run my code show me this: It looks like you didn't add 'make' => 'BMW' to the associative array.

<?php
    // This is an array using integers as the indices.
    // Add 'BMW' as the last element in the array!
    $car = array(2012, 'blue', 5, 'BMW');

    // This is an associative array.
    // Add the make => 'BMW' key/value pair!
    $assocCar = array('year' => 2012,
               'colour' => 'blue',
               'doors' => 5,
               'make' => 'BMW');
        
    // This code should output "BMW"...
    echo $car[3];
    echo '<br />';
        
    // ...and so should this!
    echo $assocCar['make'];

Someone help me?


#2

SOLVED! The editor don't show me a crash window and my last code(considered). Only in PHP exercises happen this. =(


#3

What I found I had to do with a lot of the PHP exercises is that after a first error i had to reload the page, so i would copy all of the code and refresh and then paste it back in, and this normally fixed any problems, including failing the exercise.