[#270] Learn SQL - many exercises - correct code not accepted

sql
bug-reported

#1

Exercises are not checking my code correctly. Gives me an error no matter what I put in as the code.

I am on a MAC, OS X Yosemite. I am using Chrome as my web browser and attached a screen shot of it failing.


#2

@stkm90,
Have you tried a Refresh Browser

Always refresh the browser after making corrections:
CTRL f5 ( if on Windows or Linux)
CMD r ( if on a MAC).


#3

Not only did I try refreshing the browser, but I tried completely closing the browser and opening codecademy back up again. I also used the help feature to restart the lesson. This problem was happening with every lesson I did today in Learn SQL, not just lesson show above.


#4

@stkm90,
IMHO
you code looks Ok.

The only possibility left is to keep re-try-ing
untill you are asked
"Do you want the Code" or "Keep trying"

Then take the option to get the code.....

I think they are checking the =input= field for an expected code
inclusive =spaces= and so on...
If you have used cut&paste it might be a hidden character has been passed on....


#5

I have the same Problem - and the workarround with several tries works, but is very annoying. Please fix


#6

Hi there, for some time i can't do part of the sql lessons.
No matter what i will type in code editor, i'm still getting "Type code in the code editor using the appriopriate function" error, funny thing is that the queries are working as they should(i hope).
Screenshot of the error:
Bug?


#7

This is something new, I can reproduce it and have reported it.


#8

FYI i'm also seeing this error, still happening... thanks!


#9

I am also experiencing the same thing. I even tried "Get Help" -> "I want to restart this exercise" -> "Restart this exercise" to reset my files and clearing my browsers cache for codeacademy.com. I'm also on Mac, OS X El Cap, Chrome. I can click the "Run" button a few times and it gives me the code, but when I get to the next Lesson, I hit the same problem.


#10

Mine looks alright. I just have tested it.

Try lowercase: select, from, group by. Both lower and uppercase should be ok.


#11

Did you reset the exercise and try again or was that from before yesterday?


#12

Am I missing something or is this broken?

The instructions for the exercise are (copied and pasted):

Let's continue with the SELECT statement. In the code editor, type

SELECT DISTINCT genre FROM movies;

Did you notice anything about the output?

This is what I typed in the code editor:

SELECT DISTINCT genre FROM movies;

And this is the error message I get:

Type the code in the code editor using the appropriate clause.


#13

In my previous reply I ran the code again without resetting.

Now I reset it and ran it again; same problem like the others have mentioned.

However, after 3 tries, it offers GET CODE which actually gives you the code for the second part of the exercise and you can proceed to the next.


#14

I keep getting the error 'Type to code into the code editor using the appropriate function, clause, and operator'.
It says to
1.
Count the total number of apps at each price that have been downloaded more than 20,000 times. In the code editor type

SELECT price, COUNT(*) FROM fake_apps
WHERE downloads > 20000
GROUP BY price;

I get the right query results on the right....Am I missing something really obvious?


#15

I tried that. But I end up with the same issue on the next exercise. :frowning:


#16

Whenever I run the code, code editor returns "Type the code in the code editor using the appropriate function." How ever I write the same as written in instructions.


#17

I am having this trouble as well. It is quite annoying because it was pretty fun while it worked.


#18

In the instructions, they have asked to type this:
SELECT name, imdb_rating FROM movies;

I entered the same in the code editor. It provided me with the correct output still it is giving a CROSS mark (X) in the instruction check box giving the error as follows:
Type the statement in the code editor.

I have stuck on this since when and im not able to proceed ahead due to this. Please help.!!!


#19

I have the same problem !


#20

I think it is a bug. It keeps coming up all the way through this exercise - I have reported it to Codecademy.