26/26 What am I doing wrong?


#1

It's telling me I forgot to set my text-decoration to "none", but I didn't!

a {
text-decoration: none;
color: #cc0000
}

Help, pls!


#2

Hi @bash_cat,

Have you tried adding a semi-colon to the line below it? This seems to solve your problem:

a {
  text-decoration:none;
  color: #cc0000; #add the semi-colon here
}

#3

I have the same problem, but I already had the semicolon there.
I've pasted the whole CSS in, just in case there is an error earlier in the code.

I'm not sure what's going wrong here.

My HTML:

<a href="url">Link text</a>

My CSS:

    img {
        height: 100px;
        width: 300px;
        border: 1px solid #4682b4;
    h1 {
        font-family: Verdana, sans-serif;
        color: #576D94;
    }
    p {
        font-family: Garamond, serif;
        font-size: 18px;
        color: #4A4943;
    }
    a {
        text-decoration: none;
        color: #cc0000;
    }

#4

You forgot to put a closing bracket after the css for the img. It should look like this:

   img {
        height: 100px;
        width: 300px;
        border: 1px solid #4682b4;
    } 
    h1 {
        font-family: Verdana, sans-serif;
        color: #576D94;
    }
    p {
        font-family: Garamond, serif;
        font-size: 18px;
        color: #4A4943;
    }
    a {
        text-decoration: none;
        color: #cc0000;
    }

#5

I works now, thanks.


#6

Hi , I have the same problem I have all the code right but still saying:
Oops, try again. Did you remember to give your image a 1px solid #4682b4 border?
My code is
img {
height: 100px;
width: 300px;
border: 1px solid #4682b4;
}
h1 {
font-family: Verdana, sans-serif;
color: #576D94;
}
p {
font-family: Garamond, serif;
font-size: 18px;
color: #4A4943;
}


#7

me too

the code is rigth, but I still read the "oops try again" message.

I've tried with many browsers


#8

btw you can solve the problem by "cheating" with your html

I did like this

<img style= "border: 1px solid #4682b4; height:100px;width: 300px;"src="http://3.bp.blogspot.com/-iG51X3XlLeU/VZKFjP3KmAI/AAAAAAAAD4w/biIp9fnoIos/s1600/Thug%2BLife.jpg"/>

works fine, but you have to keep the css too.

same with unit 26.


#9

run the string like this:
img {
height:100px;
width:300px;
border-width:1px;
border-color:#4682b4;
border-style: solid;
}

And it will work!


#10

More of the same issue with my code. And from an earlier bug which I worked around in submitting.


#11

I've tried rewriting this as many ways as I can for 2 hours now.


#12

Not "border-size", just "border" (or try "border-width") :wink:


#13

fixed border-size: to border: and it works to submit. However, the border on my page view is now missing. lol


#14

This exercise was for the parameters. Now you know them. In the next exercise it should teach you how to make it appear.