25 size and borders


#1

Hi !

I'm having the same problem. I guess I also have a stupid mistake somewhere but I can't find it... The error seems to be with border.


25.Size and borders (my img syntax isn't working)
#2

Here is the stylesheet.css:


#3

Did you check your browser zoom? Otherwise, try a different browser, could be a glitch. If it is not, please copy paste your code to the forum


#4

It was indeed a problem with the zoom. I thought it was only with Firefox (I use Chrome)...

Thank you very much!!!


#5

No, all browser have zoom


#6

I have tried everything, and I cannot seem to solve the problem. A glitch with Firefox?

here:


#7

Did you make sure the browser zoom was set correctly? Otherwise try a different browser as workaround


#8

Yes, I set the zoom. I guess I'll just try a different browser.


#11

What is the relationship between zoom and border?


#12

Well, the zoom influences the border-width. When the zoom is increased (the reverse is obviously true for zooming out), the border-width increases.


#13

But what if zoom=100% in 3 different browsers. Why border-widtn not equal 1px?


#14

Well, can i see your html and css code? Please copy and paste it to the forum.


#15

@arcsurfer34700, no need to post in multiply topics.


#16
   <link type='text/css'; rel='stylesheet'; href='stylesheet.css';

/>
Is it wrong?


#17

Could you post your full html and css code? I don't want to do this in stages


#18

I put this code and it works but I still do not understand why.

<!DOCTYPE html>
<html>
	<head>
	    <link type='text/css'; rel='stylesheet'; href='stylesheet.css'; />
		<title>Result</title>
	</head>
	<body>
	   <img src='http://i1061.photobucket.com/albums/t480/ericqweinstein/46838757.png' />
	</body>
</html>

p  {font-family: Garamond, serif;}
h1 {font-family: Verdana, sans-serif;}
img {height: 100px; width: 300px; border: 1px solid #4682b4}

#19

because it is almost the correct code? the attributes (type, rel and href) in your <link> should be separated by spaces only, no semi-colons. So yes, this should pass


#20

Mine was the same as yours and it didn't work in google chrome but I put my code in firefox and it worked.


#21

Yes, that's browser glitch, I had same problem on chrome(48.0.2564.116 m), but I put code in IE11 and it worked too.


#22

Wish I had looked here sooner ... spent way too much time trying to figure this out. Thanks!