2. Taking Up Space - Oops error! (bug?)


#1

I've been stuck on this part for some time that I've skipped it, trying to come back to it from time to time.

The instructions say to change the display mode to "block" and I think that is exactly what I've done in the code!

The error that I get is - "Oops, try again!" which doesn't tell me much about what the actual code is supposed to work.

Is it a bug? Pleas help me out! Thanks,
Adam


* {
	border: 1px dashed blue;
}

div {
	height: 50px;
	width: 100px;
	border: 2px solid black;
	border-radius: 5px;
	/*Add your CSS here!*/
	display: block;
}

#one {
	background-color: #FF0000;
}

#two {
	background-color: #0000FF;
}

#three {
	background-color: #FFD700;
}

#four {
	background-color: #308014;
}


#2

Hello @punchki,

Your code should work fine. Try refreshing the page, that fixes the problem sometimes. If the problem continues to persist, reply with details such as your Operating System and browser. That may be the source of the problem...


#3

Hey, I have tried now with both Google Chrome and Mozilla Firefox, and both are giving me the same errors. I am running Ghost Windows 7 (however I am in china for 2 months, so I am on a Chinese computer for now)


#4

Hey @punchki,

I have absolutely no idea why only this exercise isn't working for you... I'll refer you to a moderator and see what I can do.


#5

OK, thanks! :slight_smile: love the site btw


#6

Can we see your html code?


#7

I haven't touched the original HTML code:

here it is!

<!DOCTYPE html>
<html>
    <head>
        <link type="text/css" rel="stylesheet" href="stylesheet.css"/>
        <title>Result</title>
    </head>
    <body>
        <div id="one"></div>
        <div id="two"></div>
        <div id="three"></div>
        <div id="four"></div>
    </body>
</html>


#8

see reply up, sorry didn't hit the right reply button


#9

Everything is as it should be. And different browser didn't work either?


#10

I also have this problem and I'm in China too. Can anyone help me with this?


#11

please create a new topic with your code + error message + question so someone can help you


#12

I have tried 4 browsers now - Chrome, firefox, opera, and chinese 360 browser (very similar to IE). Still no luck. Is it possible to have the lesson checked as completed for me? I know perfectly what it does, just want it out of the way


#13

Hi,

Yes this looks like a bug but this doesn't happen to all users just some unfortunate users :cry:

However I have found a work around, do the following:

  1. Logout of Codecademy
  2. Go to https://www.codecademy.com/courses/web-beginner-en-6merh/0/2
  3. Click save and submit once it shows that you passed don't click to go to the next leeson
  4. You will see create account or login on the top right hand side corner, click on login and put in your login details.

Now you will see that your lesson will be checked as passed :slight_smile:

Hope it works and sorry for the inconvenience :green_heart:


#14

Hey! I'm also currently in China and was having the same problem with this exercise in particular. I was able to pass it after using a VPN. I wonder if it has something to do with the page needing to load something from Google, which is blocked here?

On a side note, the entire site became much faster after using the VPN!


#15

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.