15/16 help


#1

I’ve filled the ___ with %s, the backslash is at the end of line 5 and the console returns:

What is your name?What is your quest?What is your favorite color?Ah, so your name is SCT, your quest is if type(error) == ValueError:, and your favorite color is return "Make sure to use a lowercase “s” with %s. Python told us about the following error: " + str(error).

The console waits a second after the first question, but I can’t write anything. Since this happens in other exercises, can we propperly say it’s a bug?


15/16 Help
#2

Ok, but it looks the same problem I have. The input and the oputput are the same in the same exercise.


#3

Hello @berfraper,

It appears that many of our users are running into this issue. We are looking into it. :slight_smile:


#4

Yes, yes we are… this should be updated already


#5

Hello @berfraper,

Have you tried overwriting the variables like this?

name = raw_input("What is your name?")
quest = raw_input("What is your quest?")
color = raw_input("What is your favorite color?")
name = "name"
quest = "quest"
color = "color"

Let me know if this works for you.


#6

use this to bypass the activity,



name = 'ash'
quest = 'be the very best'
color = 'red'
print "Ah, so your name is %s, your quest is %s, " \
"and your favorite color is %s." % (name, quest, color)


#8

Hmm… the “Next” button activates, but the console returns either the first question or every question and answers, it doesn’t allow me to input anything in both cases. I’ve copied the code to a notepad and it works as intended after running the script a few times. The same happened with Ruby, just to add some more info about the problem.


#9

well for now just trying to find a way around it is better then being stuck till its fixed.


#10

So you have tested the code I posted above and it doesn’t work on Codecademy (along with the print statement given on the lesson)? Have you tried what @paulaswam quoted by any chance?


#11

I was writing the reply and I didn’t notice, I’ll try that later


#14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.