11/18 Hey i can't Figure out what's wrong here, can any1 help


#1

class Angle
include Math

attr_accessor :radians

def initialize(radians)
@radians = radians
end

def cosine
cos(@radians)
end
end

acute = Angle.new(1)
acute.cosine

Error :Did you include Math on line 2


#2

Refreshing Page, got it moving ! that's odd, but anyways, Solved !


#3

The only follow up comment I'd like to make is that on the previous exercise (10/18) the syntax was a bit different:

require 'date',

with single quotes and not capitalized... Then

Include Math

Where "Math" is capitalized but no quote marks are needed. Something to note for the future, I guess?


#4

Exactly my problem with this exercise, I was really sure I answered it right. Then I found some code here showing only a capital letter, I tried it and it worked. So, I'm a little bothered nothing in the instruction told me about it.

Tried to look for a way to report it, but before I do that they say: "Read our troubleshoothing guide first!" and when I click on that, the page is missing. I'm gonna leave this mystery unexplained while I continue my course :slightly_smiling:


#5

Thank you for the tips about refreshing the page. Indeed it only works when one refreshes the page


#6

Yep, cheers - had the same problem and only works once you refresh the page.


#7

Strange, it worked for me even though I didn’t refresh the page. Odd.


#8

Possibly patched. But, not sure.