10/13 Error, Even the solution code won't work... x.x


#1

Hello, I've been doing the Java tutorial and its been working fine up until now.
On step 10 it asks me to create a void method, which I did. But somehow it still didn't work.... So I figured I must have done something wrong. I kept trying but nothing worked, so I gave up and fetched the solution code... Only problem is the solution code won't work either ._. Nothing lets me past this step. Here's the code I'm using right now:

class Dog {
  
  int age;

	public Dog(int dogsAge) {
    
  	age = dogsAge;
    
  }
  
  public void bark() {
		
    System.out.println("Woof!");
    
	}
	
  public void run(int feet) {
    
    System.out.println("Your dog ran " + feet + " feet!");

	}
  
	public static void main(String[] args) {
    
    Dog spike = new Dog(5);
    spike.bark();
    spike.run(40);

	}

}

What should I do? I submitted a bug report but I'm unsure if there's anything else wrong... I mean this is the fetched solution...


#2

Could we get a screenshot of your whole browser so that we can see which checkpoint you are at?


#3

5 posts were split to a new topic: Did you create the run method?


#7

2 posts were split to a new topic: I don't know what i did wrong


#10


#11

@esuye, I can't see your checkpoints in that image. I need to see which of the instructions have turned green.


#12


#13

Thank you for your prompt response. Here is a new screenshot that shows the instructions turned green.


#14

As you can see it, all instructions turned green and the NEXT button is not activated. I can't progress to the next section.


#15

Thank your for that screenshot. Could I get another one that shows step 4 as green please?


#16

here it is


#17

Thanks, that's perfect!

Could I get you to try using the "I want to restart this exercise" option under the Get Help button.

If that still doesn't work, could I get:

  • your operating system
  • all of the web browsers that you've tried this with
  • are you behind a firewall
  • are you on a home/school/work network

#18

I am having issues with this as well. It just doesn't seem to validate.


#19

Take your main method and move it so that it is the last method in the class. Then reposition your run method.


#20

@albionsrefuge 's suggestion does solve the problem. As far as the Java compiler and interpreter are concerned, @raptormike 's positioning of the run method is acceptable, but Codecademy wants it to be between the bark and main methods.

After the run method has been created and the Run button has been pressed in step 1 of this exercise, the method can be moved elsewhere without a problem. But in step 1, Codecademy looks for it in the prescribed place within the code.

It is best not to move it, because it may mess the order up in succeeding exercises.


#21

I have the exact same problem. :[

Very frustrating. wtf?


#22

I just tried something which worked and maybe revealed the bug.

I restarted the exercise, then went step by step.

Please keep in mind that:

  1. All my steps were checked green except for the last, for which I resorted to fetching the solution code.
    1. I had already tried going step by step after having retrieved the solution code a few times (which never worked). I emulated the solution code closely, the only difference being that I inserted my own value for the "feet" integer.

I decided to use the exact integer that the solution code used (even though that should be irrelevant) (my integer was 100).
In the place where you enter the integer to denote "feet" i entered the number 40 just like in the solution code, written thusly:

spike.run(40);

Guess what! It worked. I can now move on to the next buggy lesson. :[ :[ :[


#23

Also, the "report a bug" link appears broken.


#24

Same problem here, can you fix this or give a solution to continu the exercice?


#25

I have the same problem. Putting 40 after restart does not help. What can I do to go to next page?